论坛首页新手上路 签到
查看: 1232|回复: 0

[知识分享] 招聘基于ggglmk升级和数据模型必填属性分享

[复制链接]
wisedu-liujianbo

该用户从未签到

6

主题

6

帖子

18

积分

初来乍到

Rank: 1

积分
18
发表于 2020-7-14 17:52:26 | 显示全部楼层 |阅读模式
本帖最后由 liujianbo 于 2020-7-14 17:52 编辑

1.招聘从4.0.25开始支持pg数据库(包括4.0.25)
2.如果现场版本低于4.0.25,建议不要升级ggglmk,有可能会导致查询报错,例如字段重复等:
如果现场已经升级了ggglmk,则需要二开对招聘进行定制,保证适配ggglmk的公共语法

lALPD2eDM8DHbIbNAkjNB2E_1889_584.png

3.如果现场定制的过程中,表增加了字段,同步数据模型时尽量不要在数据模型上设置必填属性,如果需要使用必填属性,在引用的业务模型上设置
必填属性。因为如果该数据模型设置必填后,该表在其他应用中使用,调用的是DsUtil.saveOrUpdate方法,这个必填字段没有被赋值,会导致保存或更新方法报错。
例子: 现场定制过T_TBSZ_TBLB,增加了字段DZ_KHLX,招聘种类保存时,因为没有为该必填字段赋值,导致后台保存报错了。 lALPD3Irr6-UMG7NA5nNBcg_1480_921.png lALPD4BhqkKnsCPNA3rNBzA_1840_890.png 1594719677574_43930EFD-B383-430b-BBD1-B07988959FBC.png
您需要登录后才可以回帖 登录 | 加入我们

本版积分规则

Archiver|手机版|小黑屋|江苏金智教育信息股份有限公司 ( 系统管理员:binmeng@wisedu.com  

GMT+8, 2021-3-8 17:06

Powered by Discuz! X3.2

© 2015 Design: www.wisedu.com

快速回复 返回顶部 返回列表